Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.6

Bug #17380 Specifying Trust DB Breaks Module
Submitted: 2010-05-07 20:37 UTC
From: cyberis Assigned: gauthierm
Status: Closed Package: Crypt_GPG (version 1.1.0)
PHP Version: 5.3.2 OS: FC12
Roadmaps: (Not assigned)    
Subscription  


 [2010-05-07 20:37 UTC] cyberis (Chris Bortz)
Description: ------------ If you specify the trustdb in the options array then it improperly adds the --trustdb-name parameter to the gpg command line. The problem is the lack of a space between the option name and the option value. a space needs to be added in Engine.php on line 1445 in the string '--trustdb-name' so that it is now '-- trustdb-name '. This fixes the problem.

Comments

 [2010-05-08 00:02 UTC] gauthierm (Michael Gauthier)
-Status: Open +Status: Closed -Assigned To: +Assigned To: gauthierm
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. http://svn.php.net/viewvc?view=revision&revision=299119 I'll do a quick bug-fix release so you can start using the fix as soon as possible.
 [2010-05-08 00:06 UTC] gauthierm (Michael Gauthier)
Crypt_GPG-1.1.1 is now released and fixes this bug.