Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.6

Bug #17569 ReferralServer support
Submitted: 2010-07-06 23:00 UTC
From: hm2k Assigned: kguest
Status: Closed Package: Net_Whois (version SVN)
PHP Version: Irrelevant OS:
Roadmaps: 1.0.4    
Subscription  


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 33 + 35 = ?

 
 [2010-07-06 23:00 UTC] hm2k (James Wade)
Description: ------------ Most IP addresses utilise the ReferralServer field for rwhois. It works in an identical way to regular whois, but you must follow the data in the ReferralServer to call the correct details. Details on the rwhois protocol can be found here: https://www.arin.net/meetings/minutes/ARIN_XII/PDF/Wednesday/DBWG_Leibzon.pdf http://projects.arin.net/rwhois/ http://en.wikipedia.org/wiki/RWhois It's perhaps worth noting that this works in a very similar way to the existing "authoritative" lookups. Support for rwhois would permit IP lookups to work as expected, rather than returning limited details.

Comments

 [2010-07-08 21:51 UTC] hm2k (James Wade)
-Summary: rwhois support +Summary: ReferralServer support -Type: Feature/Change Request +Type: Bug
I've changed this to a bug, as it was previously working, but it isn't. The problem is due to the matching that is used, as now the hosts are FQDN and have a trailing ".", where as before they didn't. A quick fix would be to trim the hosts as they are matched. FIND if (strstr($line, $this->_nicServers[$ipNicServer])) { CHANGE TO if (strstr($line, trim($this->_nicServers[$ipNicServer],'.'))) { A long term fix would be to swap out this method with proper rwhois support. eg: $pattern='#ReferralServer: whois://(.+?):43#'; Please don't hesitate to use the quick fix, then modify this back to a feature request. Thanks.
 [2010-07-25 12:51 UTC] hm2k (James Wade)
 [2010-07-25 16:41 UTC] kguest (Ken Guest)
-Assigned To: +Assigned To: kguest
 [2010-07-25 16:44 UTC] kguest (Ken Guest)
-Roadmap Versions: +Roadmap Versions: 1.0.4
 [2010-07-25 16:44 UTC] kguest (Ken Guest)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.