Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.7

Bug #18526 Hang on file decryption
Submitted: 2011-05-11 18:58 UTC
From: dustinfineout Assigned: gauthierm
Status: Duplicate Package: Crypt_GPG (version 1.2.0)
PHP Version: 5.3.6 OS: RHEL
Roadmaps: (Not assigned)    
Subscription  


 [2011-05-11 18:58 UTC] dustinfineout (Dustin Fineout)
Description: ------------ Most files decrypt with no problem. However some hang at a certain point and won't continue. Here is debug output when attempting to decrypt with a private key (this is the same exact code/key that executes error free for other files, also this same file decrypts fine from the command line). Crypt_GPG DEBUG: OPENING SUBPROCESS WITH THE FOLLOWING COMMAND: Crypt_GPG DEBUG: /usr/bin/gpg --status-fd '3' --command-fd '4' --no-secmem-warning --no-tty --no-default-keyring --no- options --no-use-agent --no-permission-warning --exit-on- status-write-error --trust-model always --homedir '/root/.gnupg' --decrypt Crypt_GPG DEBUG: BEGIN PROCESSING Crypt_GPG DEBUG: selecting streams Crypt_GPG DEBUG: => got 1 Crypt_GPG DEBUG: input stream is ready for reading Crypt_GPG DEBUG: => about to read 8192 bytes from input stream Crypt_GPG DEBUG: => read 8192 bytes Crypt_GPG DEBUG: selecting streams Crypt_GPG DEBUG: => got 2 Crypt_GPG DEBUG: GPG is ready for input Crypt_GPG DEBUG: => about to write 8192 bytes to GPG input Crypt_GPG DEBUG: => wrote 8192 bytes Crypt_GPG DEBUG: input stream is ready for reading Crypt_GPG DEBUG: => about to read 8192 bytes from input stream Crypt_GPG DEBUG: => read 8192 bytes Crypt_GPG DEBUG: selecting streams Crypt_GPG DEBUG: => got 1 Crypt_GPG DEBUG: input stream is ready for reading Crypt_GPG DEBUG: => about to read 8192 bytes from input stream Crypt_GPG DEBUG: => read 2835 bytes Crypt_GPG DEBUG: selecting streams Crypt_GPG DEBUG: => got 1 Crypt_GPG DEBUG: GPG is ready for input Crypt_GPG DEBUG: => about to write 8192 bytes to GPG input At this point the script hangs and never continues.

Comments

 [2011-06-20 21:26 UTC] gauthierm (Michael Gauthier)
-Status: Open +Status: Duplicate
Thanks for your report. This is a duplicate of Bug #18618, which has a better description of the issue.
 [2011-09-13 01:51 UTC] gauthierm (Michael Gauthier)
-Status: Duplicate +Status: Closed -Assigned To: +Assigned To: gauthierm
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2011-09-13 01:51 UTC] gauthierm (Michael Gauthier)
-Status: Closed +Status: Duplicate