Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.2

Bug #20941 NNTP Client unstable with PHP 5.5.25+ / 5.6.11+
Submitted: 2015-08-21 12:52 UTC
From: ravefiend Assigned: heino
Status: Closed Package: Net_NNTP (version Forked version of Net_NNTP)
PHP Version: 5.5.28 OS: N/A
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 49 + 47 = ?

 
 [2015-08-21 12:52 UTC] ravefiend (Pieter Breugelmans)
Description: ------------ Reference: https://github.com/spotweb/spotweb/issues/65 https://github.com/spotweb/spotweb/tree/master/NNTP The NNTP Client is shown to be unstable with the latest PHP releases that have been released since early 2015. When using SSL connections, after some time the connection gets terminated with the message 'Failed to read ...' Actual result: -------------- Fatal error occured while connecting to the newsserver: (-1) Failed to read from socket...! [response: ""] #0 /volume1/web/NNTP/Protocol/Client.php(296): Net_NNTP_Protocol_Client->throwError('Failed to read ...') #1 /volume1/web/NNTP/Protocol/Client.php(279): Net_NNTP_Protocol_Client->_getStatusResponse() #2 /volume1/web/NNTP/Protocol/Client.php(1759): Net_NNTP_Protocol_Client->_sendCommand('XOVER 425087-43...') #3 /volume1/web/NNTP/Client.php(1000): Net_NNTP_Protocol_Client->cmdXOver('425087-430087') #4 /volume1/web/lib/services/Nntp/Services_Nntp_Engine.php(137): ...

Comments

 [2015-08-21 13:58 UTC] heino (Heino H. Gehlsen)
Based on the error message ("Failed to read from socket..."), the problem seem to originate from the silenced call to fgets() at line 294 of your included version of Net_NNTP (https://github.com/spotweb/spotweb/blob/master/NNTP/Protocol/Client.php). Try removing the at-sign in front of fgets(), or add something like "var_dump(error_get_last());" in front of line 296. By the way, a reproducible problem (as it is described on the the provided link) could have to be accompanied by more detail...
 [2015-08-21 21:02 UTC] heino (Heino H. Gehlsen)
-Status: Open +Status: Bogus -Package Version: Unknown +Package Version: Forked version of Net_NNTP
The code at https://github.com/spotweb/spotweb/tree/master/NNTP is a modified version of Net_NNTP (forked Sep 6, 2011). Since this bug is not known to affect Net_NNTP, it is considered bogus - at leat until it has been verified on an actual version of Net_NNTP.
 [2016-04-04 21:40 UTC] mesa57 (Jan Franken)
This problem also occurs when I use the unmodified pear package (1.5.0 stable). So please reopen.
 [2017-07-27 15:31 UTC] heino (Heino H. Gehlsen)
-Status: Bogus +Status: Open
 [2017-08-19 00:38 UTC] heino (Heino H. Gehlsen)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: heino
Solution by Jan Franken proposed as pull request #2 at GitHub (https://github.com/pear/Net_NNTP/pull/2).
 [2017-09-24 21:04 UTC] heino (Heino H. Gehlsen)
-Status: Feedback +Status: Closed