Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.6

Bug #21074 crypt-gpg-pinentry fails on system without PEAR/Exception
Submitted: 2016-06-03 14:55 UTC
From: alec Assigned: alec
Status: Closed Package: Crypt_GPG (version 1.4.1)
PHP Version: Irrelevant OS:
Roadmaps: 1.4.2    
Subscription  


 [2016-06-03 14:55 UTC] alec (Aleksander Machniak)
Description: ------------ https://github.com/roundcube/roundcubemail/issues/5304 PEAR/Exception.php is required by Console_CommandLine. If it's not installed in the system fatal error is thrown. We could workaround it at least on composer installs. For Roundcube it would be by adding $root . $ds . '..' . $ds . '..' . $ds . 'pear' . $ds . 'pear_exception' to the include path.

Comments

 [2016-06-04 05:57 UTC] alec (Aleksander Machniak)
-Status: Open +Status: Closed -Assigned To: +Assigned To: alec
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.