Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #5733 Only variables should be assigned by reference
Submitted: 2005-10-20 17:08 UTC
From: gagsdsuro at yahoo dot ca Assigned: justinpatrin
Status: Closed Package: DB_DataObject_FormBuilder
PHP Version: 4.4.0 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 40 + 39 = ?

 
 [2005-10-20 17:08 UTC] gagsdsuro at yahoo dot ca
Description: ------------ Recently upgrade to php v.4.4.0 got "Only variables should be assigned by reference" when calling populateOptions() on line 1958 also I'm using DB_DataObject_FormBuilder 1.0.0RC2 fix: $do = DB_DataObject::factory($crossLink['table']); Test script: --------------- $fb = DB_DataObject_FormBuilder::create($do); $fb->populateOptions(); Actual result: -------------- Only variables should be assigned by reference line 1958

Comments

 [2005-10-20 17:19 UTC] justinpatrin
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. I've changed all of the DB_DataObject::factory calls not to sue =& in CVS.