Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.2

Bug #6833 mail() does not work
Submitted: 2006-02-19 00:39 UTC
From: wmark at hurrikane dot de Assigned: heino
Status: Closed Package: Net_NNTP (version 1.3.3)
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 39 + 4 = ?

 
 [2006-02-19 00:39 UTC] wmark at hurrikane dot de
Description: ------------ mail() does not work Test script: --------------- <?php require_once 'Net/NNTP/Client.php'; echo('.'); $news = new Net_NNTP_Client(); echo('.'); $tmp = $news->connect('hostname'); if(PEAR::isError($tmp)) {echo('Error');} echo('.'); $tmp = $news->authenticate('username', 'password'); if(PEAR::isError($tmp)) {echo('Error');} echo('.'); $tmp = $news->mail('group.name', 'Subject', 'Body', 'From: <somebody@example.net>'); if(PEAR::isError($tmp)) {echo('Error');} echo('.'); $news->disconnect(); ?> Expected result: ---------------- The expected behaviour is, that a new messsage shows up in the given newsgroup. Actual result: -------------- Unfortunately neither the message appears nor any error happens.

Comments

 [2006-02-19 00:43 UTC] heino at php dot net
The mail() method was not using the updated protocol API. It appears that a modification was never committed or something, since the this new medhot was actually once tested...
 [2006-02-19 11:47 UTC] wmark at hurrikane dot de
The patched revision you have send me works now. Thanks!
 [2006-02-28 17:52 UTC] heino at php dot net
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2006-06-17 22:11 UTC] heino at php dot net (Heino H. Gehlsen)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Net_NNTP