Comments for "Gtk2_VarDump"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • Alan Knowles  [2005-11-22 01:30 UTC]

    looks ok - only thing would be that the class variables could do with clearer names (and a description)
  • Scott Mattocks  [2005-11-22 13:54 UTC]

    1) I think this should be named Gtk2_VarDump. It will help keep things more organized. Packages in Gtk will be PHP-GTK 1 while packages in Gtk2 will be PHP-GTK 2. That way people using Gtk_VarDump with PHP-GTK 1 won't be as likely to upgrade to a package they can't use.

    2) Lines 124 & 125 you add two GtkTreeViews to GtkScrolledWindows using add_with_viewport. GtkTreeView doesn't need a view port. See the second paragraph here:

    3) This is a minor point but can you add more inline comments.